Mikan Network Lab.

ネットワーク技術やCisco製品に関して、勉強・検証した内容を発信しています。

Mikan Network Lab.

ASA: DHCPリレーエージェントの設定

Cisco ASAにおけるDHCPリレーエージェントの設定方法を記載します。

目次

1. 前提条件

本記事は以下に基づいて作成しています。
・Cisco VIRL 1.6.65
・Cisco ASAv Version 9.9.2

2. 要件

  • ASAのINSIDEインタフェースでDHCPリレーエージェントを有効化し、DMZインタフェースのセグメントに存在するDHCPサーバ(192.168.2.1)からIPアドレスを取得できるようにする。

3. 設定例

 ASA 

hostname ASA
!
interface GigabitEthernet0/0
 nameif INSIDE
 security-level 100
 ip address 192.168.1.254 255.255.255.0
!
interface GigabitEthernet0/1
 nameif DMZ
 security-level 50
 ip address 192.168.2.254 255.255.255.0
!
interface GigabitEthernet0/2
 nameif OUTSIDE
 security-level 0
 ip address 192.168.3.254 255.255.255.0
!
dhcprelay server 192.168.2.1 DMZ
dhcprelay enable INSIDE

  • DHCPリレーエージェントはトランスペアレントファイアウォールモードでは使用できない。
  • DHCPサーバが有効になっている場合、DHCPリレーエージェントは有効化できない。

4. 動作確認

ASA# show dhcprelay state
Context  Configured as DHCP Relay
Interface INSIDE, Configured for DHCP RELAY SERVER
Interface DMZ, Configured for DHCP RELAY
Interface OUTSIDE, Not Configured for DHCP