Mikan Network Lab.

ネットワーク技術やCisco製品に関して、勉強・検証した内容を発信しています。

Mikan Network Lab.

ASA: DHCPサーバの設定

Cisco ASAにおけるDHCPサーバの設定方法を記載します。

目次

1. 前提条件

本記事は以下に基づいて作成しています。
・Cisco VIRL 1.6.65
・Cisco ASAv Version 9.9.2

2. 要件

  • ASAでDHCPサーバを有効化し、以下のパラメータを設定する。
    • IPアドレスプール:192.168.1.1 ~ 192.168.1.10
    • デフォルトゲートウェイ:192.168.1.254
    • DNSサーバ:10.0.0.1
    • ドメイン名:example.com
    • リース期間:2時間
    • 有効化するインタフェース:INSIDE

3. 設定例

 ASA 

hostname ASA
!
interface GigabitEthernet0/0
 nameif INSIDE
 security-level 100
 ip address 192.168.1.254 255.255.255.0
!
interface GigabitEthernet0/1
 nameif DMZ
 security-level 50
 ip address 192.168.2.254 255.255.255.0
!
interface GigabitEthernet0/2
 nameif OUTSIDE
 security-level 0
 ip address 192.168.3.254 255.255.255.0
!
dhcpd dns 10.0.0.1
dhcpd lease 7200
dhcpd domain example.com
dhcpd option 3 ip 192.168.1.254
!
dhcpd address 192.168.1.1-192.168.1.10 INSIDE
dhcpd enable INSIDE

  • dhcpd leaseコマンドは秒単位で指定する。
  • dhcpd option 3 ipコマンドでデフォルトゲートウェイのIPアドレスを指定する。
  • dhcpd addressコマンドでDHCPで割り当てられるIPアドレスプールと、アドレスプールを割り当てるインタフェースを指定する。
  • dhcpd enableコマンドでDHCPサーバを有効化するインタフェースを指定する。

4. 動作確認

ASA# show dhcpd binding

IP address       Client Identifier        Lease expiration        Type

    192.168.1.1  0063.6973.636f.2d66.           7045 seconds    Automatic
                 6131.362e.3365.3533.
                 2e66.3734.392d.4769.
                 302f.31