Mikan Network Lab.

ネットワーク技術やCisco製品に関して、勉強・検証した内容を発信しています。

Mikan Network Lab.

IOS: IS-IS_同じエリア内の通信

IS-ISの同じエリア内で通信するための設定方法を記載します。

目次

1. 前提条件

本記事は以下に基づいて作成しています。
・Cisco VIRL 1.6.65
・Cisco IOS Software, Version 15.7(3)M3

2. 要件

  • R1とR2をIS-ISのレベル1ルータに設定してください。
  • R1とR2のLo0のセグメントをIS-ISで広報し、お互いに通信できるように設定してください。
  • NETはR1は「49.0012.0000.0000.0001.00」、R2は「49.0012.0000.0000.0002.00」に設定してください。

構成図

3. 設定例

要件を満たす設定例を以下に示します。

 R1 

hostname R1
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 ip router isis
!
interface GigabitEthernet0/1
 ip address 192.168.12.1 255.255.255.0
 ip router isis
!
router isis
 net 49.0012.0000.0000.0001.00
 is-type level-1
 log-adjacency-changes
!
end

 R2 

hostname R2
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
 ip router isis
!
interface GigabitEthernet0/1
 ip address 192.168.12.2 255.255.255.0
 ip router isis
!
router isis
 net 49.0012.0000.0000.0002.00
 is-type level-1
 log-adjacency-changes
!
end

4. 動作確認

4.1. show isis neighbors

  • R1とR2でIS-ISのレベル1隣接関係が確立されていることを確認します。

R1#show isis neighbors

System Id       Type Interface     IP Address      State Holdtime Circuit Id
R2              L1   Gi0/1         192.168.12.2    UP    8        R2.01
R2#show isis neighbors

System Id       Type Interface     IP Address      State Holdtime Circuit Id
R1              L1   Gi0/1         192.168.12.1    UP    23       R2.01

4.2. show ip route

  • R1のルーティングテーブルに2.2.2.2/32がIS-ISレベル1ルートとして登録されていることを確認します。
  • R2のルーティングテーブルに1.1.1.1/32がIS-ISレベル1ルートとして登録されていることを確認します。

R1#show ip route isis
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      2.0.0.0/32 is subnetted, 1 subnets
i L1     2.2.2.2 [115/20] via 192.168.12.2, 00:27:40, GigabitEthernet0/1
R2#show ip route isis
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
i L1     1.1.1.1 [115/20] via 192.168.12.1, 00:27:07, GigabitEthernet0/1

4.3. ping

  • R1とR2のLo0の間で通信できることを確認します。

R1#ping 2.2.2.2 source 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
Packet sent with a source address of 1.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/2/3 ms

5. 補足

  • デフォルトでは、IS-ISはネイバー隣接関係のログが出力されません。log-adjacency-changesコマンドを使用することでログ出力を有効化できます。