Mikan Network Lab.

ネットワーク技術やCisco製品に関して、勉強・検証した内容を発信しています。

Mikan Network Lab.

IOS: IS-IS - 異なるエリア間の通信

Cisco IOSにおけるIS-ISの異なるエリア間で通信するための設定方法を記載します。

目次

1. 前提条件

本記事は以下に基づいて作成しています。
・Cisco Modeling Labs 2.1.1
・Cisco IOS Software, Version 15.9(3)M2

2. 要件

  • R1とR4のLo0のセグメント間でお互いに通信できるように設定してください。
  • ルーティングプロトコルはIS-ISを使用してください。
  • R1とR2でレベル1隣接関係、R2とR3でレベル2隣接関係、R3とR4でレベル1隣接関係を確立させてください。
  • NETは以下の通りに設定してください。
    • R1:49.0012.0000.0000.0001.00
    • R2:49.0012.0000.0000.0002.00
    • R3:49.0023.0000.0000.0003.00
    • R4:49.0023.0000.0000.0004.00

構成図

3. 設定例

要件を満たす設定例を以下に示します。

 R1 

hostname R1 
! 
interface Loopback0 
 ip address 1.1.1.1 255.255.255.255 
 ip router isis  
! 
interface GigabitEthernet0/0 
 ip address 192.168.12.1 255.255.255.0 
 ip router isis  
! 
router isis 
 net 49.0012.0000.0000.0001.00 
 is-type level-1 
 log-adjacency-changes 
! 
end

 R2 

hostname R2 
! 
interface GigabitEthernet0/0 
 ip address 192.168.12.2 255.255.255.0 
 ip router isis  
 isis circuit-type level-1 
! 
interface GigabitEthernet0/1 
 ip address 192.168.23.2 255.255.255.0 
 ip router isis  
 isis circuit-type level-2-only  
! 
router isis 
 net 49.0012.0000.0000.0002.00 
 log-adjacency-changes 
! 
end

 R3 

hostname R3 
! 
interface GigabitEthernet0/0 
 ip address 192.168.23.3 255.255.255.0 
 ip router isis  
 isis circuit-type level-2-only 
! 
interface GigabitEthernet0/1 
 ip address 192.168.34.3 255.255.255.0 
 ip router isis  
 isis circuit-type level-1 
! 
router isis 
 net 49.0023.0000.0000.0003.00 
 log-adjacency-changes 
! 
end

 R4 

hostname R4 
! 
interface Loopback0 
 ip address 4.4.4.4 255.255.255.255 
 ip router isis  
! 
interface GigabitEthernet0/0 
 ip address 192.168.34.4 255.255.255.0 
 ip router isis  
! 
router isis 
 net 49.0023.0000.0000.0004.00 
 is-type level-1 
 log-adjacency-changes 
! 
end

4. 動作確認

4.1. show isis neighbors

  • R1とR2でIS-ISのレベル1隣接関係が確立されていることを確認。
  • R2とR3でIS-ISのレベル2隣接関係が確立されていることを確認。
  • R3とR4でIS-ISのレベル1隣接関係が確立されていることを確認。

R1#show isis neighbors

System Id       Type Interface     IP Address      State Holdtime Circuit Id 
R2              L1   Gi0/0         192.168.12.2    UP    25       R1.01
R2#show isis neighbors

System Id       Type Interface     IP Address      State Holdtime Circuit Id 
R1              L1   Gi0/0         192.168.12.1    UP    8        R1.01
R3              L2   Gi0/1         192.168.23.3    UP    28       R2.02
R3#show isis neighbors

System Id       Type Interface     IP Address      State Holdtime Circuit Id 
R2              L2   Gi0/0         192.168.23.2    UP    9        R2.02
R4              L1   Gi0/1         192.168.34.4    UP    23       R3.02
R4#show isis neighbors

System Id       Type Interface     IP Address      State Holdtime Circuit Id 
R3              L1   Gi0/0         192.168.34.3    UP    8        R3.02

4.2. show ip route

  • R1のルーティングテーブルにデフォルトルートが登録されていることを確認。
  • R4のルーティングテーブルにデフォルトルートが登録されていることを確認。

R1#show ip route isis
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area  
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2 
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2 
       ia - IS-IS inter area, * - candidate default, U - per-user static route 
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP 
       a - application route 
       + - replicated route, % - next hop override, p - overrides from PfR 

Gateway of last resort is 192.168.12.2 to network 0.0.0.0 

i*L1  0.0.0.0/0 [115/10] via 192.168.12.2, 00:09:33, GigabitEthernet0/0
R4#show ip route isis
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area  
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2 
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2 
       ia - IS-IS inter area, * - candidate default, U - per-user static route 
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP 
       a - application route 
       + - replicated route, % - next hop override, p - overrides from PfR 

Gateway of last resort is 192.168.34.3 to network 0.0.0.0 

i*L1  0.0.0.0/0 [115/10] via 192.168.34.3, 00:09:49, GigabitEthernet0/0

4.3. ping

  • R1とR4のLo0の間で通信できることを確認。

R1#ping 4.4.4.4 source 1.1.1.1
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds: 
Packet sent with a source address of 1.1.1.1  
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/5/7 ms

5. 補足

  • レベル1/2ルータは異なるエリアと接続されると、レベル1 LSPにattached bitをセットするようになります。このLSPをレベル1ルータが受信すると、レベル1/2ルータを指すデフォルトルートが生成されます。
  • レベル1 LSPにattached bitがセットされているかどうかはshow isis databaseコマンドで確認できます。

R1#show isis database

IS-IS Level-1 Link State Database: 
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime/Rcvd      ATT/P/OL 
R1.00-00            * 0x00000006   0x4A1C                 835/*         0/0/0 
R1.01-00            * 0x00000004   0x89C7                 966/*         0/0/0 
R2.00-00              0x00000008   0x7B05                 439/1199      1/0/0
R4#show isis database

IS-IS Level-1 Link State Database: 
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime/Rcvd      ATT/P/OL 
R3.00-00              0x00000008   0xFB41                1000/1199      1/0/0 
R3.02-00              0x00000003   0xC484                 374/1199      0/0/0 
R4.00-00            * 0x00000005   0x6EB0                1096/*         0/0/0