Mikan Network Lab.

ネットワーク技術やCisco製品に関して、勉強・検証した内容を発信しています。

Mikan Network Lab.

IOS-XRにおけるEBGPネイバーの設定方法

Cisco IOS-XRにおけるEBGPネイバーの設定方法を紹介します。

目次

1. コマンド一覧
2. 仕様説明
 2.1. 概要
 2.2. route-policy
 2.3. route-policy in
 2.4. route-policy out
 2.5. 参考
3. 設定例
 3.1. 要件
 3.2. コンフィグ
 3.3. 動作確認
  3.3.1. show bgp ipv4 unicast summary
  3.3.2. show bgp ipv4 unicast
  3.3.3. show bgp ipv4 unicast neighbors advertised-routes
 3.4. 補足
  3.4.1. ルートポリシーを適用しなかった場合の動作

前提条件

本記事は以下に基づいて作成しています。
・Cisco VIRL 1.6.65
・Cisco IOS XR Software, Version 6.1.3

1. コマンド一覧

本記事で重要なコマンドを以下に示します。

(config)# route-policy <name>

(config)# router bgp <as-number>
(config-bgp)# bgp router-id <ip-address>
(config-bgp)# address-family ipv4 unicast
(config-bgp-af)# network <ip-address>/<prefix>
(config-bgp)# neighbor <ip-address>
(config-bgp-nbr)# remote-as <as-number>
(config-bgp-nbr)# address-family ipv4 unicast
(config-bgp-nbr-af)# route-policy <route-policy-name> in
(config-bgp-nbr-af)# route-policy <route-policy-name> out

2. 仕様説明

2.1. 概要

Cisco IOS-XRでBGPのEBGPネイバーを確立し、EBGPでネットワークを広報するには以下の流れで設定を行います。

(1) ルートポリシーの作成
(2) BGPルーティングプロセスの有効化
(3) ルータIDの指定
(4) ルータコンフィギュレーションモードでアドレスファミリの有効化
(5) 広報するネットワークの指定
(6) ネイバールータの指定
(7) ネイバールータのAS番号の指定
(8) ネイバーコンフィギュレーションモードでアドレスファミリの有効化
(9) ルートポリシーの適用

2.2. route-policy

ルートポリシーを定義するには、グローバルコンフィギュレーションモードでroute-policyコマンドを使用します。

(config)# route-policy <name>

<name>でルートポリシーの名前を指定します。ルートポリシーを使用することで、着信ルートおよび発信ルートに対して様々な制御を行うことが可能です。

【Sample】
ルートを変更せずに無条件に許可するルートポリシーの設定例を示します。

(config)# route-policy RPL
(config-rpl)# pass

2.3. route-policy in

着信ルートにポリシーを適用するには、ネイバーアドレスファミリコンフィギュレーションモードでroute-policy inコマンドを使用します。

(config-bgp-nbr-af)# route-policy <route-policy-name> in

<route-policy-name>でルートポリシーの名前を指定します。このコマンドが設定されていない場合、EBGPでルートを受信することができません。

2.4. route-policy out

発信ルートにポリシーを適用するには、ネイバーアドレスファミリコンフィギュレーションモードでroute-policy outコマンドを使用します。

(config-bgp-nbr-af)# route-policy <route-policy-name> out

<route-policy-name>でルートポリシーの名前を指定します。このコマンドが設定されていない場合、EBGPでルートを送信することができません。

3. 設定例

3.1. 要件

  • XR1のBGPプロセスをAS番号65001で起動してください。
  • XR2のBGPプロセスをAS番号65002で起動してください。
  • BGPルータIDはLoopback0のIPアドレスを明示的に指定してください。
  • XR1とXR2でEBGPネイバーを確立し、Loopback0のネットワークを互いに広報してください。

構成図

3.2. コンフィグ

本タスクの要件を満たす設定例を以下に示します。

 XR1 

hostname XR1
interface Loopback0
 ipv4 address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/0/0/0
 ipv4 address 192.168.12.1 255.255.255.0
!
route-policy RPL
  pass
end-policy
!
router bgp 65001
 bgp router-id 1.1.1.1
 address-family ipv4 unicast
  network 1.1.1.1/32
 !
 neighbor 192.168.12.2
  remote-as 65002
  address-family ipv4 unicast
   route-policy RPL in
   route-policy RPL out
  !
 !
!
end

 XR2 

hostname XR2
interface Loopback0
 ipv4 address 2.2.2.2 255.255.255.255
!
interface GigabitEthernet0/0/0/0
 ipv4 address 192.168.12.2 255.255.255.0
!
route-policy RPL
  pass
end-policy
!
router bgp 65002
 bgp router-id 2.2.2.2
 address-family ipv4 unicast
  network 2.2.2.2/32
 !
 neighbor 192.168.12.1
  remote-as 65001
  address-family ipv4 unicast
   route-policy RPL in
   route-policy RPL out
  !
 !
!
end

3.3. 動作確認

3.3.1. show bgp ipv4 unicast summaryコマンド

  • XR1でBGPルータIDが1.1.1.1、AS番号が65001であることを確認します。
  • XR2でBGPルータIDが2.2.2.2、AS番号が65002であることを確認します。
  • XR1とXR2でEBGPネイバーが確立されていることを確認します。

RP/0/0/CPU0:XR1#show bgp ipv4 unicast summary
Sun Mar  1 06:14:45.686 UTC
BGP router identifier 1.1.1.1, local AS number 65001
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000   RD version: 4
BGP main routing table version 4
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

BGP is operating in STANDALONE mode.


Process       RcvTblVer   bRIB/RIB   LabelVer  ImportVer  SendTblVer  StandbyVer
Speaker               4          4          4          4           4           0

Neighbor        Spk    AS MsgRcvd MsgSent   TblVer  InQ OutQ  Up/Down  St/PfxRcd
192.168.12.2      0 65002       8       8        4    0    0 00:04:33          1
RP/0/0/CPU0:XR2#show bgp ipv4 unicast summary
Sun Mar  1 06:14:47.806 UTC
BGP router identifier 2.2.2.2, local AS number 65002
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000   RD version: 4
BGP main routing table version 4
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

BGP is operating in STANDALONE mode.


Process       RcvTblVer   bRIB/RIB   LabelVer  ImportVer  SendTblVer  StandbyVer
Speaker               4          4          4          4           4           0

Neighbor        Spk    AS MsgRcvd MsgSent   TblVer  InQ OutQ  Up/Down  St/PfxRcd
192.168.12.1      0 65001       8       8        4    0    0 00:04:37          1
3.3.2. show bgp ipv4 unicastコマンド

  • XR1でネットワーク2.2.2.2/32を受信していることを確認します。
  • XR2でネットワーク1.1.1.1/32を受信していることを確認します。

RP/0/0/CPU0:XR1#show bgp ipv4 unicast
Sun Mar  1 06:15:00.005 UTC
BGP router identifier 1.1.1.1, local AS number 65001
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000   RD version: 4
BGP main routing table version 4
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
              i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network            Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32         0.0.0.0                  0         32768 i
*> 2.2.2.2/32         192.168.12.2             0             0 65002 i

Processed 2 prefixes, 2 paths
RP/0/0/CPU0:XR2#show bgp ipv4 unicast
Sun Mar  1 06:15:02.645 UTC
BGP router identifier 2.2.2.2, local AS number 65002
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000   RD version: 4
BGP main routing table version 4
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
              i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network            Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32         192.168.12.1             0             0 65001 i
*> 2.2.2.2/32         0.0.0.0                  0         32768 i

Processed 2 prefixes, 2 paths
3.3.3. show bgp ipv4 unicast neighbors advertised-routes

  • XR1がネットワーク1.1.1.1/32を送信していることを確認します。
  • XR2がネットワーク2.2.2.2/32を送信していることを確認します。

RP/0/0/CPU0:XR1#show bgp ipv4 unicast neighbors 192.168.12.2 advertised-routes
Sun Mar  1 07:13:33.602 UTC
Network            Next Hop        From            AS Path
1.1.1.1/32         192.168.12.1    Local           65001i

Processed 1 prefixes, 1 paths
RP/0/0/CPU0:XR2#show bgp ipv4 unicast neighbors 192.168.12.1 advertised-routes
Sun Mar  1 07:14:23.198 UTC
Network            Next Hop        From            AS Path
2.2.2.2/32         192.168.12.2    Local           65002i

Processed 1 prefixes, 1 paths

3.4. 補足

3.4.1. ルートポリシーを適用しなかった場合の動作

EBGPでルートを送受信するには、ルートポリシーの適用が不可欠です。

(config-bgp-nbr-af)# route-policy RPL in
(config-bgp-nbr-af)# route-policy RPL out

ルートポリシーを適用しなかった場合は、以下のログが出力されます。

RP/0/0/CPU0:XR1#show logging | include BGP
Sun Mar  1 06:34:12.054 UTC

RP/0/0/CPU0:Mar  1 06:33:28.507 : bgp[1052]: %ROUTING-BGP-6-NBR_NOPOLICY : No inbound IPv4 Unicast policy is configured for eBGP neighbor 192.168.12.2. No IPv4 Unicast prefixes will be accepted from the neighbor until inbound policy is configured.
RP/0/0/CPU0:Mar  1 06:33:28.507 : bgp[1052]: %ROUTING-BGP-6-NBR_NOPOLICY : No outbound IPv4 Unicast policy is configured for eBGP neighbor 192.168.12.2. No IPv4 Unicast prefixes will be sent to the neighbor until outbound policy is configured.

show bgp ipv4 unicastコマンドを確認すると、XR1はネットワーク2.2.2.2/32を受信していないことが分かります。

RP/0/0/CPU0:XR1#show bgp ipv4 unicast
Sun Mar  1 06:35:50.847 UTC
BGP router identifier 1.1.1.1, local AS number 65001
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000   RD version: 3
BGP main routing table version 3
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
              i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network            Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32         0.0.0.0                  0         32768 i

また、show bgp ipv4 unicast neighbors 192.168.12.2 advertised-routesコマンドを確認すると、XR1はネットワーク1.1.1.1/32を送信していないことが分かります。

RP/0/0/CPU0:XR1#show bgp ipv4 unicast neighbors 192.168.12.2 advertised-routes
Sun Mar  1 06:36:08.246 UTC