Mikan Network Lab.

ネットワーク技術やCisco製品に関して、勉強・検証した内容を発信しています。

Mikan Network Lab.

IOS-XRにおけるEBGPマルチホップの設定方法

Cisco IOS-XRにおけるEBGPマルチホップの設定方法を紹介します。

目次

前提条件

本記事は以下に基づいて作成しています。
・Cisco VIRL 1.6.65
・Cisco IOS XR Software, Version 6.1.3

1. コマンド一覧

本記事で重要なコマンドを以下に示します。

(config)# router bgp <as-number>
(config-bgp)# neighbor <ip-address>
(config-bgp-nbr)# ebgp-multihop <ttl-value>

2. 仕様説明

2.1. 概要

デフォルトではEBGPにおけるBGPパケットのTTL値は1であるため、直接接続されていないルータとはEBGPネイバーを確立させることができません。

そこで、ebgp-multihopコマンドによりTTL値を変更することによって、直接接続されていないルータとの間でEBGPネイバーを確立させることができます。

2.2. ebgp-multihop

BGPパケットのTTL値を変更するには、ネイバーコンフィギュレーションモードでebgp-multihopコマンドを使用します。

(config-bgp-nbr)# ebgp-multihop <ttl-value>

<ttl-value>でTTL値を指定します。<ttl-value>を省略した場合、TTL値は255になります。

【Sample】
ネイバー2.2.2.2(最大10ホップ先)へのBGP接続を許可する設定例を示します。

(config)# router bgp 65001
(config-bgp)# neighbor 2.2.2.2
(config-bgp-nbr)# ebgp-multihop 10

3. 設定例

3.1. 要件

  • XR1のBGPプロセスをAS番号65001で起動してください。
  • XR2のBGPプロセスをAS番号65002で起動してください。
  • XR1とXR2はLoopback0を使用して、EBGPネイバーを確立してください。なお、ebgp-multihopコマンドを使用してください。

構成図

3.2. コンフィグ

本タスクの要件を満たす設定例を以下に示します。

 XR1 

hostname XR1
interface Loopback0
 ipv4 address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/0/0/0
 ipv4 address 192.168.12.1 255.255.255.0
!
route-policy RPL
  pass
end-policy
!
router static
 address-family ipv4 unicast
  2.2.2.2/32 192.168.12.2
 !
!
router bgp 65001
 address-family ipv4 unicast
 !
 neighbor 2.2.2.2
  remote-as 65002
  ebgp-multihop 255
  update-source Loopback0
  address-family ipv4 unicast
   route-policy RPL in
   route-policy RPL out
  !
 !
!
end

 XR2 

hostname XR2
interface Loopback0
 ipv4 address 2.2.2.2 255.255.255.255
!
interface GigabitEthernet0/0/0/0
 ipv4 address 192.168.12.2 255.255.255.0
!
route-policy RPL
  pass
end-policy
!
router static
 address-family ipv4 unicast
  1.1.1.1/32 192.168.12.1
 !
!
router bgp 65002
 address-family ipv4 unicast
 !
 neighbor 1.1.1.1
  remote-as 65001
  ebgp-multihop 255
  update-source Loopback0
  address-family ipv4 unicast
   route-policy RPL in
   route-policy RPL out
  !
 !
!
end

3.3. 動作確認

3.3.1. show bgp ipv4 unicast summary

  • XR1とXR2でEBGPネイバーが確立されていることを確認します。

RP/0/0/CPU0:XR1#show bgp ipv4 unicast summary
Sat Mar 14 00:19:09.230 UTC
BGP router identifier 1.1.1.1, local AS number 65001
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000   RD version: 2
BGP main routing table version 2
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

BGP is operating in STANDALONE mode.


Process       RcvTblVer   bRIB/RIB   LabelVer  ImportVer  SendTblVer  StandbyVer
Speaker               2          2          2          2           2           0

Neighbor        Spk    AS MsgRcvd MsgSent   TblVer  InQ OutQ  Up/Down  St/PfxRcd
2.2.2.2           0 65002      11      13        2    0    0 00:05:16          0
RP/0/0/CPU0:XR2#show bgp ipv4 unicast summary
Sat Mar 14 00:19:17.279 UTC
BGP router identifier 2.2.2.2, local AS number 65002
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000   RD version: 2
BGP main routing table version 2
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

BGP is operating in STANDALONE mode.


Process       RcvTblVer   bRIB/RIB   LabelVer  ImportVer  SendTblVer  StandbyVer
Speaker               2          2          2          2           2           0

Neighbor        Spk    AS MsgRcvd MsgSent   TblVer  InQ OutQ  Up/Down  St/PfxRcd
1.1.1.1           0 65001      12      11        2    0    0 00:05:24          0