Mikan Network Lab.

ネットワーク技術やCisco製品に関して、勉強・検証した内容を発信しています。

Mikan Network Lab.

IOS-XR: IBGPネイバーの設定方法

Cisco IOS-XRにおけるIBGPネイバーの設定方法を紹介します。

目次

前提条件

本記事は以下に基づいて作成しています。
・Cisco VIRL 1.6.65
・Cisco IOS XR Software, Version 6.1.3

1. コマンド一覧

本記事で重要なコマンドを以下に示します。

(config)# router bgp <as-number>
(config-bgp)# bgp router-id <ip-address>
(config-bgp)# address-family ipv4 unicast
(config-bgp-af)# network <ip-address>/<prefix>
(config-bgp)# neighbor <ip-address>
(config-bgp-nbr)# remote-as <as-number>
(config-bgp-nbr)# address-family ipv4 unicast

2. 仕様説明

2.1. 概要

Cisco IOS-XRでBGPのIBGPネイバーを確立し、IBGPでネットワークを広報するには以下の流れで設定を行います。

(1) BGPルーティングプロセスの有効化
(2) ルータIDの指定
(3) ルータコンフィギュレーションモードでアドレスファミリの有効化
(4) 広報するネットワークの指定
(5) ネイバールータの指定
(6) ネイバールータのAS番号の指定
(7) ネイバーコンフィギュレーションモードでアドレスファミリの有効化

2.2. router bgp

BGPプロセスを有効化するには、グローバルコンフィギュレーションモードでrouter bgpコマンドを使用します。

(config)# router bgp <as-number>

<as-number>で自ルータが属するAS番号を指定します。AS番号の指定方法には以下の3通りがあります。

・2バイトのAS番号:範囲は1~65535です。
・asplain形式の4バイトAS番号:範囲は1~4294967295です。
・asdot形式の4バイトのAS番号:範囲は1.0~65535.65535です。

【Sample】
BGPプロセスをAS番号65001で起動する設定例を示します。

(config)# router bgp 65001

2.3. bgp router-id

BGPルータIDを指定するには、ルータコンフィギュレーションモードでbgp router-idコマンドを使用します。

(config-bgp)# bgp router-id <ip-address>

<ip-address>でルータIDを指定します。ルータIDは32ビットの値で、IPv4アドレスと同じフォーマットで指定します。bgp router-idコマンドを使用してルータIDが設定されていない場合は、Loopbackインタフェースで設定されている最大IPアドレスが使用されます。bgp router-idコマンドが使用されておらず、LoopbackインタフェースでもIPアドレスが設定されていない場合は、BGPネイバーを確立させることができません。

【Sample】
BGPルータIDを1.1.1.1に指定する設定例を示します。

(config)# router bgp 65001
(config-bgp)# bgp router-id 1.1.1.1

2.4. address-family ipv4 unicast

IPv4ユニキャストアドレスファミリを有効化するには、ルータコンフィギュレーションモードとネイバーコンフィギュレーションモードの両方でaddress-family ipv4 unicastコマンドを使用します。

(config-bgp)# address-family ipv4 unicast
(config-bgp-nbr)# address-family ipv4 unicast

【Sample】
ネイバー192.168.12.2に対するIPv4ユニキャストアドレスファミリを有効化する設定例を示します。

(config)# router bgp 65001
(config-bgp)# address-family ipv4 unicast
(config-bgp-af)# exit
(config-bgp)# neighbor 192.168.12.2
(config-bgp-nbr)# address-family ipv4 unicast

2.5. network

ネットワークを広報するには、アドレスファミリコンフィギュレーションモードでnetworkコマンドを使用します。

(config-bgp-af)# network <ip-address>/<prefix>

<ip-address>で広報するネットワークのアドレス、<prefix>でネットワークのプレフィックス長を指定します。なお、このコマンドで指定されたネットワークは、ルーティングテーブルにそのネットワークへのルートが存在する場合に限り、ネイバーに広報されます。

【Sample】
ネットワーク1.1.1.1/32を広報する設定例を示します。

(config)# router bgp 65001
(config-bgp)# address-family ipv4 unicast
(config-bgp-af)# network 1.1.1.1/32

2.6. neighbor

ネイバールータを指定するには、ルータコンフィギュレーションモードでneighborコマンドを使用します。

(config-bgp)# neighbor <ip-address>

<ip-address>でネイバールータのIPアドレスを指定します。

【Sample】
IPアドレス192.168.12.2をネイバールータに指定する設定例を示します。

(config)# router bgp 65001
(config-bgp)# neighbor 192.168.12.2

2.7. remote-as

ネイバールータのAS番号を指定するには、ネイバーコンフィギュレーションモードでremote-asコマンドを使用します。

(config-bgp-nbr)# remote-as <as-number>

<as-number>でネイバールータが属するAS番号を指定します。

【Sample】
ネイバールータ192.168.12.2のAS番号を65001に指定する設定例を示します。

(config)# router bgp 65001
(config-bgp)# neighbor 192.168.12.2
(config-bgp-nbr)# remote-as 65001

3. 設定例

3.1. 要件

  • BGPプロセスをAS番号65001で起動してください。
  • BGPルータIDはLoopback0のIPアドレスを明示的に指定してください。
  • XR1とXR2でIBGPネイバーを確立し、Loopback0のネットワークを互いに広報してください。

構成図

3.2. コンフィグ

本タスクの要件を満たす設定例を以下に示します。

 XR1 

hostname XR1
interface Loopback0
 ipv4 address 1.1.1.1/32
!
interface GigabitEthernet0/0/0/0
 ipv4 address 192.168.12.1/24
!
router bgp 65001
 bgp router-id 1.1.1.1
 address-family ipv4 unicast
  network 1.1.1.1/32
 !
 neighbor 192.168.12.2
  remote-as 65001
  address-family ipv4 unicast
  !
 !
!
end

 XR2 

hostname XR2
interface Loopback0
 ipv4 address 2.2.2.2/32
!
interface GigabitEthernet0/0/0/0
 ipv4 address 192.168.12.2/24
!
router bgp 65001
 bgp router-id 2.2.2.2
 address-family ipv4 unicast
  network 2.2.2.2/32
 !
 neighbor 192.168.12.1
  remote-as 65001
  address-family ipv4 unicast
  !
 !
!
end

3.3. 動作確認

3.3.1. show bgp ipv4 unicast summary

  • XR1でBGPルータIDが1.1.1.1、AS番号が65001であることを確認します。
  • XR2でBGPルータIDが2.2.2.2、AS番号が65001であることを確認します。
  • XR1とXR2でIBGPネイバーが確立されていることを確認します。

RP/0/0/CPU0:XR1#show bgp ipv4 unicast summary
Sat Feb 29 13:29:21.881 UTC
BGP router identifier 1.1.1.1, local AS number 65001
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000   RD version: 4
BGP main routing table version 4
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

BGP is operating in STANDALONE mode.


Process       RcvTblVer   bRIB/RIB   LabelVer  ImportVer  SendTblVer  StandbyVer
Speaker               4          4          4          4           4           0

Neighbor        Spk    AS MsgRcvd MsgSent   TblVer  InQ OutQ  Up/Down  St/PfxRcd
192.168.12.2      0 65001       8       9        4    0    0 00:04:55          1
RP/0/0/CPU0:XR2#show bgp ipv4 unicast summary
Sat Feb 29 13:30:04.788 UTC
BGP router identifier 2.2.2.2, local AS number 65001
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000   RD version: 4
BGP main routing table version 4
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

BGP is operating in STANDALONE mode.


Process       RcvTblVer   bRIB/RIB   LabelVer  ImportVer  SendTblVer  StandbyVer
Speaker               4          4          4          4           4           0

Neighbor        Spk    AS MsgRcvd MsgSent   TblVer  InQ OutQ  Up/Down  St/PfxRcd
192.168.12.1      0 65001       9       9        4    0    0 00:05:39          1
3.3.2. show bgp ipv4 unicast

  • XR1でネットワーク2.2.2.2/32を受信していることを確認します。
  • XR2でネットワーク1.1.1.1/32を受信していることを確認します。

RP/0/0/CPU0:XR1#show bgp ipv4 unicast
Sat Feb 29 13:29:41.549 UTC
BGP router identifier 1.1.1.1, local AS number 65001
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000   RD version: 4
BGP main routing table version 4
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
              i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network            Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32         0.0.0.0                  0         32768 i
*>i2.2.2.2/32         192.168.12.2             0    100      0 i

Processed 2 prefixes, 2 paths
RP/0/0/CPU0:XR2#show bgp ipv4 unicast
Sat Feb 29 13:30:14.817 UTC
BGP router identifier 2.2.2.2, local AS number 65001
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000   RD version: 4
BGP main routing table version 4
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
              i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network            Next Hop            Metric LocPrf Weight Path
*>i1.1.1.1/32         192.168.12.1             0    100      0 i
*> 2.2.2.2/32         0.0.0.0                  0         32768 i

Processed 2 prefixes, 2 paths
3.3.3. show bgp ipv4 unicast neighbors advertised-routes

  • XR1がネットワーク1.1.1.1/32を送信していることを確認します。
  • XR2がネットワーク2.2.2.2/32を送信していることを確認します。

RP/0/0/CPU0:XR1#show bgp ipv4 unicast neighbors 192.168.12.2 advertised-routes
Wed Mar  4 06:12:39.019 UTC
Network            Next Hop        From            AS Path
1.1.1.1/32         192.168.12.1    Local           i

Processed 1 prefixes, 1 paths
RP/0/0/CPU0:XR2#show bgp ipv4 unicast neighbors 192.168.12.1 advertised-routes
Wed Mar  4 06:13:08.847 UTC
Network            Next Hop        From            AS Path
2.2.2.2/32         192.168.12.2    Local           i

Processed 1 prefixes, 1 paths