Mikan Network Lab.

ネットワーク技術やCisco製品に関して、勉強・検証した内容を発信しています。

Mikan Network Lab.

IOS-XRにおけるBGPルートリフレクタの設定方法

Cisco IOS-XRにおけるBGPルートリフレクタの設定方法を紹介します。

目次

前提条件

本記事は以下に基づいて作成しています。
・Cisco VIRL 1.6.65
・Cisco IOS XR Software, Version 6.1.3

1. コマンド一覧

本記事で重要なコマンドを以下に示します。

(config)# router bgp <as-number>
(config-bgp)# neighbor <ip-address>
(config-bgp-nbr)# address-family ipv4 unicast
(config-bgp-nbr-af)# route-reflector-client

2. 仕様説明

2.1. 概要

IBGPではループ防止のためのBGPスプリットホライズンにより、IBGPで受信したルートは他のIBGPネイバーに広報されません。そのため、IBGPネイバーはフルメッシュで構成する必要があります。フルメッシュでの構成はルータ数が増えれば増えるほど、IBGPネイバーの増加に伴うルータの負荷や、設定数の増加に伴う運用上の負荷が高くなります。

そこで、ルートリフレクタを使用することによって、フルメッシュ構成が不要となります。ルートリフレクタに設定されたルータはIBGPで受信したルートを反射できるため、周囲のIBGPネイバーであるルートリフレクタクライアントはルートリフレクタのみとIBGPネイバーを確立すればよいからです。

2.2. route-reflector-client

ローカルルータをルートリフレクタとして設定し、指定したネイバーをルートリフレクタクライアントとして設定するには、ネイバーアドレスファミリコンフィギュレーションモードでroute-reflector-clientコマンドを使用します。

(config-bgp-nbr-af)# route-reflector-client

【Sample】
ローカルルータをルートリフレクタ、ネイバー2.2.2.2をルートリフレクタクライアントにする設定例を示します。

(config)# router bgp 65001
(config-bgp)# neighbor 2.2.2.2
(config-bgp-nbr)# address-family ipv4 unicast
(config-bgp-nbr-af)# route-reflector-client

3. 設定例

3.1. 要件

  • BGPプロセスをAS番号65001で起動してください。
  • XR2をルートリフレクタ、XR1とXR3をルートリフレクタクライアントに設定してください。
  • XR1とXR3でLoopback10のネットワークをIBGPで広報し、互いのネットワークを受信していることを確認してください。

構成図

3.2. コンフィグ

本タスクの要件を満たす設定例を以下に示します。

 XR1 

hostname XR1
interface Loopback0
 ipv4 address 1.1.1.1/32
!
interface Loopback10
 ipv4 address 11.11.11.11/32
!
interface GigabitEthernet0/0/0/0
 ipv4 address 192.168.12.1/24
!
router ospf 1
 area 0
  interface Loopback0
  !
  interface GigabitEthernet0/0/0/0
  !
 !
!
router bgp 65001
 address-family ipv4 unicast
  network 11.11.11.11/32
 !
 neighbor 2.2.2.2
  remote-as 65001
  update-source Loopback0
  address-family ipv4 unicast
  !
 !
!
end

 XR2 

hostname XR2
interface Loopback0
 ipv4 address 2.2.2.2/32
!
interface GigabitEthernet0/0/0/0
 ipv4 address 192.168.12.2/24
!
interface GigabitEthernet0/0/0/1
 ipv4 address 192.168.23.2/24
!
router ospf 1
 area 0
  interface Loopback0
  !
  interface GigabitEthernet0/0/0/0
  !
  interface GigabitEthernet0/0/0/1
  !
 !
!
router bgp 65001
 address-family ipv4 unicast
 !
 neighbor 1.1.1.1
  remote-as 65001
  update-source Loopback0
  address-family ipv4 unicast
   route-reflector-client
  !
 !
 neighbor 3.3.3.3
  remote-as 65001
  update-source Loopback0
  address-family ipv4 unicast
   route-reflector-client
  !
 !
!
end

 XR3 

hostname XR3
interface Loopback0
 ipv4 address 3.3.3.3/32
!
interface Loopback10
 ipv4 address 33.33.33.33/32
!
interface GigabitEthernet0/0/0/0
 ipv4 address 192.168.23.3/24
!
router ospf 1
 area 0
  interface Loopback0
  !
  interface GigabitEthernet0/0/0/0
  !
 !
!
router bgp 65001
 address-family ipv4 unicast
  network 33.33.33.33/32
 !
 neighbor 2.2.2.2
  remote-as 65001
  update-source Loopback0
  address-family ipv4 unicast
  !
 !
!
end

3.3. 動作確認

3.3.1. show bgp ipv4 unicast

  • XR1でネットワーク33.33.33.33/32を受信していることを確認します。
  • XR3でネットワーク11.11.11.11/32を受信していることを確認します。

RP/0/0/CPU0:XR1#show bgp ipv4 unicast
Sun Mar  8 14:04:16.471 UTC
BGP router identifier 1.1.1.1, local AS number 65001
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000   RD version: 4
BGP main routing table version 4
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
              i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network            Next Hop            Metric LocPrf Weight Path
*> 11.11.11.11/32     0.0.0.0                  0         32768 i
*>i33.33.33.33/32     3.3.3.3                  0    100      0 i

Processed 2 prefixes, 2 paths
RP/0/0/CPU0:XR3#show bgp ipv4 unicast
Sun Mar  8 14:04:23.941 UTC
BGP router identifier 3.3.3.3, local AS number 65001
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000   RD version: 4
BGP main routing table version 4
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
              i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network            Next Hop            Metric LocPrf Weight Path
*>i11.11.11.11/32     1.1.1.1                  0    100      0 i
*> 33.33.33.33/32     0.0.0.0                  0         32768 i

Processed 2 prefixes, 2 paths