Mikan Network Lab.

ネットワーク技術やCisco製品に関して、勉強・検証した内容を発信しています。

Mikan Network Lab.

IOS-XRにおけるLoopback I/Fを用いたBGPネイバーの設定方法

Cisco IOS-XRにおけるLoopbackインタフェースを用いたBGPネイバーの設定方法を紹介します。

目次

1. コマンド一覧
2. 仕様説明
 2.1. update-source
3. 設定例
 3.1. 要件
 3.2. コンフィグ
 3.3. 動作確認
  3.3.1. show bgp ipv4 unicast summary

前提条件

本記事は以下に基づいて作成しています。
・Cisco VIRL 1.6.65
・Cisco IOS XR Software, Version 6.1.3

1. コマンド一覧

本記事で重要なコマンドを以下に示します。

(config)# router bgp <as-number>
(config-bgp)# neighbor <ip-address>
(config-bgp-nbr)# update-source <interface>

2. 仕様説明

2.1. update-source

Loopbackインタフェースを用いてネイバーを確立するには、ネイバーコンフィギュレーションモードでupdate-sourceコマンドを使用します。

(config-bgp-nbr)# update-source <interface>

<interface>でネイバーを確立する際に使用するインタフェースを指定します。Loopbackインタフェースを指定することで、アウトバウンドインタフェースがダウンした場合でもネイバーへの別のルートがあればBGPセッションをアップのままにすることができます。

3. 設定例

3.1. 要件

  • BGPプロセスをAS番号65001で起動してください。
  • XR1とXR2はLoopback0を使用して、IBGPネイバーを確立するようにしてください。

構成図

3.2. コンフィグ

本タスクの要件を満たす設定例を以下に示します。

 XR1 

hostname XR1
interface Loopback0
 ipv4 address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/0/0/0
 ipv4 address 192.168.12.1 255.255.255.0
!
router ospf 1
 area 0
  interface Loopback0
  !
  interface GigabitEthernet0/0/0/0
  !
 !
!
router bgp 65001
 address-family ipv4 unicast
 !
 neighbor 2.2.2.2
  remote-as 65001
  update-source Loopback0
  address-family ipv4 unicast
  !
 !
!
end

 XR2 

hostname XR2
interface Loopback0
 ipv4 address 2.2.2.2 255.255.255.255
!
interface GigabitEthernet0/0/0/0
 ipv4 address 192.168.12.2 255.255.255.0
!
router ospf 1
 area 0
  interface Loopback0
  !
  interface GigabitEthernet0/0/0/0
  !
 !
!
router bgp 65001
 address-family ipv4 unicast
 !
 neighbor 1.1.1.1
  remote-as 65001
  update-source Loopback0
  address-family ipv4 unicast
  !
 !
!
end

3.3. 動作確認

3.3.1. show bgp ipv4 unicast summary

  • XR1とXR2でIBGPネイバーが確立されていることを確認します。

RP/0/0/CPU0:XR1#show bgp ipv4 unicast summary
Sat Mar  7 06:33:05.067 UTC
BGP router identifier 1.1.1.1, local AS number 65001
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000   RD version: 2
BGP main routing table version 2
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

BGP is operating in STANDALONE mode.


Process       RcvTblVer   bRIB/RIB   LabelVer  ImportVer  SendTblVer  StandbyVer
Speaker               2          2          2          2           2           0

Neighbor        Spk    AS MsgRcvd MsgSent   TblVer  InQ OutQ  Up/Down  St/PfxRcd
2.2.2.2           0 65001      11      10        2    0    0 00:08:33          0
RP/0/0/CPU0:XR2#show bgp ipv4 unicast summary
Sat Mar  7 06:33:11.756 UTC
BGP router identifier 2.2.2.2, local AS number 65001
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000   RD version: 2
BGP main routing table version 2
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

BGP is operating in STANDALONE mode.


Process       RcvTblVer   bRIB/RIB   LabelVer  ImportVer  SendTblVer  StandbyVer
Speaker               2          2          2          2           2           0

Neighbor        Spk    AS MsgRcvd MsgSent   TblVer  InQ OutQ  Up/Down  St/PfxRcd
1.1.1.1           0 65001      10      11        2    0    0 00:08:39          0