Mikan Network Lab.

ネットワーク技術やCisco製品に関して、勉強・検証した内容を発信しています。

Mikan Network Lab.

IOS-XR: EIGRP - 有効化

Cisco IOS-XRでEIGRPを有効化する設定方法を紹介します。

目次

1. コマンド一覧
2. 仕様説明
 2.1. 概要
 2.2. router eigrpコマンド
 2.3. address-family ipv4コマンド
 2.4. router-idコマンド
 2.5. interfaceコマンド
3. 設定例
 3.1. 要件
 3.2. コンフィグ
 3.3. 動作確認
  3.3.1. show protocols ipv4 eigrp
  3.3.2. show eigrp ipv4 interfaces
  3.3.3. show eigrp ipv4 neighbors
  3.3.4. show route eigrp

前提条件

本記事は以下に基づいて作成しています。
・Cisco VIRL 1.6.65
・Cisco IOS XR Software, Version 6.1.3

1. コマンド一覧

本記事で必要なコマンドを以下に示します。

(config)# router eigrp <as-number>
(config-eigrp)# address-family ipv4
(config-eigrp-af)# router-id <router-id>
(config-eigrp-af)# interface <interface>

2. 仕様説明

2.1. 概要

Cisco IOS-XRでEIGRPを有効化するには以下の流れで設定を行います。

(1) EIGRPルーティングプロセスの有効化
(2) アドレスファミリの指定
(3) ルータIDの指定
(4) EIGRPを有効化するインタフェースの指定

なお、ルータIDの指定は必須ではありませんが、ルータの再起動などの要因で意図せずルータIDが変わることを防ぐため、ルータIDを指定することをお勧めします。

2.2. router eigrpコマンド

EIGRPプロセスを起動するには、router eigrpコマンドを使用します。

(config)# router eigrp <as-number>

<as-number>でAS番号を指定します。AS番号は1~65535の範囲で指定し、ネイバールータと一致させる必要があります。なお、EIGRPで用いられるAS番号はBGPのAS番号とは意味が異なるので混同しないように注意してください。

【Sample】
AS番号1のEIGRPプロセスを起動する設定例を示します。

(config)# router eigrp 1

2.3. address-family ipv4コマンド

Cisco IOS-XRのEIGRPでは、EIGRPプロセスを起動したあとにアドレスファミリを指定する必要があります。IPv4アドレスファミリを指定するには、address-family ipv4コマンドを使用します。

(config-eigrp)# address-family ipv4

2.4. router-idコマンド

EIGRPプロセスのルータIDを設定するには、router-idコマンドを使用します。

(config-eigrp-af)# router-id <router-id>

<router-id>でEIGRPのルータIDを指定します。ルータIDは32ビットの値で、IPv4アドレスと同じフォーマットで指定します。ルータIDは自動的にセットされるため、本コマンドは必須ではありませんが、ルータの再起動などの要因で意図せずルータIDが変わることを防ぐため、本コマンドでルータIDを指定することをお勧めします。なお、ルータIDは他のEIGRPルータと重複してはいけません。

【Sample】
ルータIDを「1.1.1.1」に設定する例を示します。

(config)# router eigrp 1
(config-eigrp)# address-family ipv4
(config-eigrp-af)# router-id 1.1.1.1

2.5. interfaceコマンド

EIGRPを有効化するインタフェースを指定するには、interfaceコマンドを使用します。

(config-eigrp-af)# interface <interface>

<interface>でEIGRPを有効化するインタフェースを指定します。

【Sample】
Gi0/0/0/0でEIGRPを有効化する設定例を示します。

(config)# router eigrp 1
(config-eigrp)# address-family ipv4
(config-eigrp-af)# interface GigabitEthernet0/0/0/0

3. 設定例

3.1. 要件

  • XR1とXR2でEIGRPを次の通りに設定してください。
    • EIGRPプロセスをAS番号1で起動すること。
    • ルータIDはLo0のIPアドレスとすること。
    • Gi0/0/0/0とLo0でEIGRPを有効化すること。

構成図

3.2. コンフィグ

本タスクの要件を満たす設定例を以下に示します。

 XR1 

hostname XR1
interface Loopback0
 ipv4 address 1.1.1.1/32
!
interface GigabitEthernet0/0/0/0
 ipv4 address 192.168.12.1/24
!
router eigrp 1
 address-family ipv4
  router-id 1.1.1.1
  interface Loopback0
  !
  interface GigabitEthernet0/0/0/0
  !
 !
!
end

 XR2 

hostname XR2
interface Loopback0
 ipv4 address 2.2.2.2/32
!
interface GigabitEthernet0/0/0/0
 ipv4 address 192.168.12.2/24
!
router eigrp 1
 address-family ipv4
  router-id 2.2.2.2
  interface Loopback0
  !
  interface GigabitEthernet0/0/0/0
  !
 !
!
end

3.3. 動作確認

3.3.1. show protocols ipv4 eigrp

show protocols ipv4 eigrpコマンドで以下を確認します。
・XR1でEIGRP AS番号が1、ルータIDが1.1.1.1であること。
・XR2でEIGRP AS番号が1、ルータIDが2.2.2.2であること。

RP/0/0/CPU0:XR1#show protocols ipv4 eigrp
Sat Feb 15 02:35:26.550 UTC

Routing Protocol: EIGRP, instance 1
Default context AS: 1, Router ID: 1.1.1.1
  Address Family: IPv4
   Default networks not flagged in outgoing updates
   Default networks not accepted from incoming updates
   Distance: internal 90, external 170
   Maximum paths: 4
   EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0, K6=0
   EIGRP metric rib scale 128
   EIGRP metric version 64-bit
   EIGRP maximum hopcount 100
   EIGRP maximum metric variance 1
   EIGRP NSF: enabled
    NSF-aware route hold timer is 480s
    NSF signal timer is 20s
    NSF converge timer is 300s
    Time since last restart is 00:05:44
   SIA Active timer is 180s
   Interfaces:
    Loopback0
    GigabitEthernet0/0/0/0
RP/0/0/CPU0:XR2#show protocols ipv4 eigrp
Sat Feb 15 02:36:06.827 UTC

Routing Protocol: EIGRP, instance 1
Default context AS: 1, Router ID: 2.2.2.2
  Address Family: IPv4
   Default networks not flagged in outgoing updates
   Default networks not accepted from incoming updates
   Distance: internal 90, external 170
   Maximum paths: 4
   EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0, K6=0
   EIGRP metric rib scale 128
   EIGRP metric version 64-bit
   EIGRP maximum hopcount 100
   EIGRP maximum metric variance 1
   EIGRP NSF: enabled
    NSF-aware route hold timer is 480s
    NSF signal timer is 20s
    NSF converge timer is 300s
    Time since last restart is 00:06:03
   SIA Active timer is 180s
   Interfaces:
    Loopback0
    GigabitEthernet0/0/0/0
3.3.2. show eigrp ipv4 interfaces

show eigrp ipv4 interfacesコマンドで以下を確認します。
・XR1とXR2のLo0とGi0/0/0/0でEIGRPが有効化されていること。

RP/0/0/CPU0:XR1#show eigrp ipv4 interfaces
Sat Feb 15 02:40:00.601 UTC

IPv4-EIGRP Interfaces for AS(1)

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Gi0/0/0/0          1        0/0        26       0/10         128           0
Lo0                0        0/0         0     640/640          0           0
RP/0/0/CPU0:XR2#show eigrp ipv4 interfaces
Sat Feb 15 02:40:04.800 UTC

IPv4-EIGRP Interfaces for AS(1)

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Gi0/0/0/0          1        0/0        23       0/10         112           0
Lo0                0        0/0         0     640/640          0           0
3.3.3. show eigrp ipv4 neighbors

show eigrp ipv4 neighborsコマンドで以下を確認します。
・XR1とXR2でEIGRPネイバーが確立されていること。

RP/0/0/CPU0:XR1#show eigrp ipv4 neighbors
Sat Feb 15 02:40:48.847 UTC

IPv4-EIGRP Neighbors for AS(1) VRF default

H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.168.12.2            Gi0/0/0/0         11 00:10:42   26   200  0  3
RP/0/0/CPU0:XR2#show eigrp ipv4 neighbors
Sat Feb 15 02:40:46.018 UTC

IPv4-EIGRP Neighbors for AS(1) VRF default

H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.168.12.1            Gi0/0/0/0         14 00:10:39   23   200  0  3
3.3.4. show route eigrp

show route eigrpコマンドで以下を確認します。
・XR1で2.2.2.2/32のルートを学習していること。
・XR2で1.1.1.1/32のルートを学習していること。

RP/0/0/CPU0:XR1#show route eigrp
Sat Feb 15 02:41:21.105 UTC

D    2.2.2.2/32 [90/10752] via 192.168.12.2, 00:11:14, GigabitEthernet0/0/0/0
RP/0/0/CPU0:XR2#show route eigrp
Sat Feb 15 02:41:24.955 UTC

D    1.1.1.1/32 [90/10752] via 192.168.12.1, 00:11:02, GigabitEthernet0/0/0/0