Mikan Network Lab.

ネットワーク技術やCisco製品に関して、勉強・検証した内容を発信しています。

Mikan Network Lab.

IOS-XR: EIGRP - パッシブインタフェース

Cisco IOS-XRにおけるEIGRPパッシブインタフェースの設定方法を紹介します。

目次

1. コマンド一覧
2. 仕様説明
 2.1. 概要
 2.2. passive-interfaceコマンド
3. 設定例
 3.1. 要件
 3.2. コンフィグ
 3.3. 動作確認
  3.3.1. show protocols ipv4 eigrp

前提条件

本記事は以下に基づいて作成しています。
・Cisco VIRL 1.6.65
・Cisco IOS XR Software, Version 6.1.3

1. コマンド一覧

本記事で必要なコマンドを以下に示します。

(config)# router eigrp <as-number>
(config-eigrp)# address-family ipv4
(config-eigrp-af)# interface <interface>
(config-eigrp-af-if)# passive-interface

2. 仕様説明

2.1. 概要

EIGRPのパッシブインタフェースとはHelloパケットの送受信を停止させたインタフェースのことです。EIGRPでは隣接ルータの有無に関係なく、EIGRPが有効化されたインタフェースからHelloパケットが送信されます。PCやサーバなどEIGRPに参加しないデバイスのみが接続されているインタフェースではHelloパケットの送信は必要ないため、一般的にパッシブインタフェースに設定します。

2.2. passive-interfaceコマンド

特定のインタフェースをパッシブインタフェースに設定するには、インタフェースコンフィギュレーションモードでpassive-interfaceコマンドを使用します。

(config-eigrp-af-if)# passive-interface

【Sample】
Gi0/0/0/0をパッシブインタフェースに設定する例を示します。

(config)# router eigrp 1
(config-eigrp)# address-family ipv4
(config-eigrp-af)# interface GigabitEthernet0/0/0/0
(config-eigrp-af-if)# passive-interface

3. 設定例

3.1. 要件

  • XR1とXR2でEIGRPを次の通りに設定してください。
    • EIGRPプロセスをAS番号1で起動すること。
    • Gi0/0/0/0とGi0/0/0/1でEIGRPを有効化すること。
    • Gi0/0/0/1をパッシブインタフェースに設定すること。

構成図

3.2. コンフィグ

本タスクの要件を満たす設定例を以下に示します。

 XR1 

hostname XR1
interface Loopback0
 ipv4 address 1.1.1.1/32
!
interface GigabitEthernet0/0/0/0
 ipv4 address 192.168.12.1/24
!
interface GigabitEthernet0/0/0/1
 ipv4 address 172.16.1.1/24
!
router eigrp 1
 address-family ipv4
  interface GigabitEthernet0/0/0/0
  !
  interface GigabitEthernet0/0/0/1
   passive-interface
  !
 !
!
end

 XR2 

hostname XR2
interface Loopback0
 ipv4 address 2.2.2.2/32
!
interface GigabitEthernet0/0/0/0
 ipv4 address 192.168.12.2/24
!
interface GigabitEthernet0/0/0/1
 ipv4 address 172.16.2.2/24
!
router eigrp 1
 address-family ipv4
  interface GigabitEthernet0/0/0/0
  !
  interface GigabitEthernet0/0/0/1
   passive-interface
  !
 !
!
end

3.3. 動作確認

3.3.1. show protocols ipv4 eigrp

show protocols ipv4 eigrpで以下を確認します。
・XR1のGi0/0/0/1がパッシブインタフェースに設定されていること。
・XR2のGi0/0/0/1がパッシブインタフェースに設定されていること。

RP/0/0/CPU0:XR1#show protocols ipv4 eigrp
Sun Feb 16 02:48:40.202 UTC

Routing Protocol: EIGRP, instance 1
Default context AS: 1, Router ID: 1.1.1.1
  Address Family: IPv4
   Default networks not flagged in outgoing updates
   Default networks not accepted from incoming updates
   Distance: internal 90, external 170
   Maximum paths: 4
   EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0, K6=0
   EIGRP metric rib scale 128
   EIGRP metric version 64-bit
   EIGRP maximum hopcount 100
   EIGRP maximum metric variance 1
   EIGRP NSF: enabled
    NSF-aware route hold timer is 480s
    NSF signal timer is 20s
    NSF converge timer is 300s
    Time since last restart is 01:43:53
   SIA Active timer is 180s
   Interfaces:
    GigabitEthernet0/0/0/0
    GigabitEthernet0/0/0/1, passive
RP/0/0/CPU0:XR2#show protocols ipv4 eigrp
Sun Feb 16 02:48:45.731 UTC

Routing Protocol: EIGRP, instance 1
Default context AS: 1, Router ID: 2.2.2.2
  Address Family: IPv4
   Default networks not flagged in outgoing updates
   Default networks not accepted from incoming updates
   Distance: internal 90, external 170
   Maximum paths: 4
   EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0, K6=0
   EIGRP metric rib scale 128
   EIGRP metric version 64-bit
   EIGRP maximum hopcount 100
   EIGRP maximum metric variance 1
   EIGRP NSF: enabled
    NSF-aware route hold timer is 480s
    NSF signal timer is 20s
    NSF converge timer is 300s
    Time since last restart is 00:53:10
   SIA Active timer is 180s
   Interfaces:
    GigabitEthernet0/0/0/0
    GigabitEthernet0/0/0/1, passive