Mikan Network Lab.

ネットワーク技術やCisco製品に関して、勉強・検証した内容を発信しています。

Mikan Network Lab.

IOS-XR: EIGRP - Helloインターバル、Holdタイム

Cisco IOS-XRでのEIGRP Helloインターバル、Holdタイムの設定方法を紹介します。

目次

1. コマンド一覧
2. 仕様説明
 2.1. 概要
 2.2. hello-intervalコマンド
 2.3. hold-timeコマンド
3. 設定例
 3.1. 要件
 3.2. コンフィグ
 3.3. 動作確認
  3.3.1. show eigrp ipv4 interfaces detail
  3.3.2. show eigrp ipv4 neighbors

前提条件

本記事は以下に基づいて作成しています。
・Cisco VIRL 1.6.65
・Cisco IOS XR Software, Version 6.1.3

1. コマンド一覧

本記事で必要なコマンドを以下に示します。

(config)# router eigrp <as-number>
(config-eigrp)# address-family ipv4
(config-eigrp-af)# interface <interface>
(config-eigrp-af-if)# hello-interval <seconds>
(config-eigrp-af-if)# hold-time <seconds>

2. 仕様説明

2.1. 概要

EIGRPを有効化させたインタフェースからは定期的にHelloパケットが送信されます。このHelloパケットの送信間隔のことをHelloインターバルといいます。Helloインターバルはインタフェースの種類によって、デフォルト値が異なります。代表的なインタフェースは以下の通りです。

・T1帯域幅(1.544Mbps)以下のマルチポイント回線:60秒
・イーサネット、PPP、T1帯域幅を超えるマルチポイント回線:5秒

定期的に送信されるHelloパケットを一定時間受信できないと、ネイバーがダウンしたとみなします。このダウンしたとみなすまでの時間のことをHoldタイムといいます。Holdタイムはインタフェースの種類によって、デフォルト値が異なります。代表的なインタフェースは以下の通りです。

・T1帯域幅(1.544Mbps)以下のマルチポイント回線:180秒
・イーサネット、PPP、T1帯域幅を超えるマルチポイント回線:15秒

なお、EIGRPではHelloインターバル、Holdタイムを隣接ルータと一致させなくてもネイバー関係を確立させることができます。

2.2. hello-intervalコマンド

Helloインターバルを設定するには、インタフェースコンフィギュレーションモードでhello-intervalコマンドを使用します。

(config-eigrp-af-if)# hello-interval <seconds>

<seconds>でHelloパケットの送信間隔を指定します。値は1~65535の範囲で指定します。

【Sample】
Gi0/0/0/0でHelloインターバルを15秒に設定する例を示します。

(config)# router eigrp 1
(config-eigrp)# address-family ipv4
(config-eigrp-af)# interface GigabitEthernet0/0/0/0
(config-eigrp-af-if)# hello-interval 15

2.3. hold-timeコマンド

Holdタイムを設定するには、インタフェースコンフィギュレーションモードでhold-timeコマンドを使用します。

(config-eigrp-af-if)# hold-time <seconds>

<seconds>でネイバーがダウンしたとみなすまでの時間を指定します。値は1~65535の範囲で指定します。

hole-timeコマンドの注意すべき点は、hold-timeコマンドで指定した値は自ルータではなくネイバー側で用いられるところです。例えば、ルータAでHoldタイムを30秒に設定すると、この値はネイバーであるルータBに通知され、ルータBはルータAからHelloパケットを30秒間受信しなかった場合にルータAをダウンしたとみなします。

【Sample】
Gi0/0/0/0でHoldタイムを30秒に設定する例を示します。

(config)# router eigrp 1
(config-eigrp)# address-family ipv4
(config-eigrp-af)# interface GigabitEthernet0/0/0/0
(config-eigrp-af-if)# hold-time 30

3. 設定例

3.1. 要件

  • XR1とXR2でEIGRPを次の通りに設定してください。
    • EIGRPプロセスをAS番号1で起動すること。
    • Gi0/0/0/0でEIGRPを有効化すること。
    • Gi0/0/0/0でHelloインターバルを10秒、Holdタイムを30秒とすること。

構成図

3.2. コンフィグ

本タスクの要件を満たす設定例を以下に示します。

 XR1 

hostname XR1
interface Loopback0
 ipv4 address 1.1.1.1/32
!
interface GigabitEthernet0/0/0/0
 ipv4 address 192.168.12.1/24
!
router eigrp 1
 address-family ipv4
  interface GigabitEthernet0/0/0/0
   hello-interval 10
   hold-time 30
  !
 !
!
end

 XR2 

hostname XR2
interface Loopback0
 ipv4 address 2.2.2.2/32
!
interface GigabitEthernet0/0/0/0
 ipv4 address 192.168.12.2/24
!
router eigrp 1
 address-family ipv4
  interface GigabitEthernet0/0/0/0
   hello-interval 10
   hold-time 30
  !
 !
!
end

3.3. 動作確認

3.3.1. show eigrp ipv4 interfaces detail

show eigrp ipv4 interfaces detailコマンドで以下を確認します。
・XR1のGi0/0/0/0でHelloインターバルが10秒、Holdタイムが30秒になっていること。
・XR2のGi0/0/0/0でHelloインターバルが10秒、Holdタイムが30秒になっていること。

RP/0/0/CPU0:XR1#show eigrp ipv4 interfaces detail
Tue Feb 18 14:01:39.983 UTC

IPv4-EIGRP Interfaces for AS(1)

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Gi0/0/0/0          1        0/0         9       0/10           0           0
  Hello interval is 10 sec, hold time is 30 sec
  BFD disabled, BFD interval 150 msec, BFD multiplier is 3
  Next xmit serial <none>
  Un/reliable mcasts: 0/0  Un/reliable ucasts: 0/3
  Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 0
  Retransmissions sent: 1  Out-of-sequence rcvd: 0
  Bandwidth percent is 50
  Total packets received: 46
  Authentication mode is not set
  Classic peers : 0, Wide peers: 1
  Effective Metric:
    Bandwidth: 1000000 Kbit, Delay: 10000000 picosecond,
    Reliability: 255, Load: 1, MTU: 1500
RP/0/0/CPU0:XR2#show eigrp ipv4 interfaces detail
Tue Feb 18 14:02:38.109 UTC

IPv4-EIGRP Interfaces for AS(1)

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Gi0/0/0/0          1        0/0        29       0/10           0           0
  Hello interval is 10 sec, hold time is 30 sec
  BFD disabled, BFD interval 150 msec, BFD multiplier is 3
  Next xmit serial <none>
  Un/reliable mcasts: 0/0  Un/reliable ucasts: 2/1
  Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 1
  Retransmissions sent: 0  Out-of-sequence rcvd: 1
  Bandwidth percent is 50
  Total packets received: 52
  Authentication mode is not set
  Classic peers : 0, Wide peers: 1
  Effective Metric:
    Bandwidth: 1000000 Kbit, Delay: 10000000 picosecond,
    Reliability: 255, Load: 1, MTU: 1500
3.3.2. show eigrp ipv4 neighbors

show eigrp ipv4 neighborsコマンドで以下を確認します。
・XR1とXR2でEIGRPネイバーが確立されていること。

RP/0/0/CPU0:XR1#show eigrp ipv4 neighbors
Tue Feb 18 14:04:41.770 UTC

IPv4-EIGRP Neighbors for AS(1) VRF default

H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.168.12.2            Gi0/0/0/0         22 00:08:30    9   200  0  1
RP/0/0/CPU0:XR2#show eigrp ipv4 neighbors
Tue Feb 18 14:04:47.850 UTC

IPv4-EIGRP Neighbors for AS(1) VRF default

H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.168.12.1            Gi0/0/0/0         23 00:08:34   29   200  0  2