Mikan Network Lab.

ネットワーク技術やCisco製品に関して、勉強・検証した内容を発信しています。

Mikan Network Lab.

IOS-XR: OSPF - 外部ルートの経路集約

Cisco IOS-XRではOSPFの経路集約をABRまたはASBRで行うことができます。本記事では、ASBRで経路集約を行う方法を紹介します。

目次

1. コマンド一覧
2. 仕様説明
 2.1. summary-prefixコマンド
3. 設定例
 3.1. 要件
 3.2. コンフィグ
 3.3. 解説
 3.4. 動作確認
  3.4.1. show route ospf
  3.4.2. ping

前提条件

本記事は以下に基づいて作成しています。
・Cisco VIRL 1.6.65
・Cisco IOS XR Software, Version 6.1.3

1. コマンド一覧

本記事で必要なコマンドを以下に示します。

(config)# router ospf <process-name>
(config-ospf)# summary-prefix <ip-address>/<prefix>

2. 仕様説明

2.1. summary-prefixコマンド

OSPFの経路集約は自動的に行われないため、手動で設定する必要があります。手動での経路集約の方法はABRで行う方法とASBRで行う方法があります。ABRではエリア間ルート(LSAタイプ3)の経路集約を行い、ASBRでは外部ルート(LSAタイプ5)の経路集約を行います。OSPFではABR、ASBR以外のルータで経路集約はできません。

ASBRで外部ルートの経路集約を行うには、summary-prefixコマンドを使用します。

(config-ospf)# summary-prefix <ip-address>/<prefix>

<ip-address>で集約ルートのネットワークアドレス、<prefix>でネットワークのプレフィックス長を指定します。

経路集約を設定したASBRのルーティングテーブルには、ループ回避のため、Null0ルートが自動的にインストールされます。

【Sample】
外部ルート172.16.0.0/24、172.16.1.0/24を集約し、172.16.0.0/23としてアドバタイズする設定例を示します。

(config)# router ospf 1
(config-ospf-ar)# summary-prefix 172.16.0.0/23

3. 設定例

3.1. 要件

  • XR1、XR2でEIGRPを次の通りに設定してください。
    • AS番号1でEIGRPプロセスを起動すること。
    • ルータIDはLo0のIPアドレスとすること。
    • XR1とXR2でEIGRPネイバーを確立すること。
    • XR1のLo10、Lo11、Lo12、Lo13をEIGRPで広報すること。

  • XR2、XR3でOSPFを次の通りに設定してください。
    • OSPFプロセス名は1とすること。
    • ルータIDはLo0のIPアドレスとすること。
    • XR2とXR3でOSPFネイバーを確立すること。

  • XR2で再配送を次の通りに設定してください。
    • EIGRPとOSPFで双方向に再配送すること。
    • EIGRPの172.16.0.0/24、172.16.1.0/24、172.16.2.0/24、172.16.3.0/24を経路集約し、172.16.0.0/22としてOSPFに再配送すること。

  • XR3からXR1のLo10、Lo11、Lo12、Lo13に到達性があることを確認してください。

構成図

3.2. コンフィグ

本タスクの要件を満たす設定例を以下に示します。

 XR1 

hostname XR1
interface Loopback0
 ipv4 address 1.1.1.1/32
!
interface Loopback10
 ipv4 address 172.16.0.1/24
!
interface Loopback11
 ipv4 address 172.16.1.1/24
!
interface Loopback12
 ipv4 address 172.16.2.1/24
!
interface Loopback13
 ipv4 address 172.16.3.1/24
!
interface GigabitEthernet0/0/0/0
 ipv4 address 192.168.12.1/24
!
router eigrp 1
 address-family ipv4
  router-id 1.1.1.1
  interface Loopback10
  !
  interface Loopback11
  !
  interface Loopback12
  !
  interface Loopback13
  !
  interface GigabitEthernet0/0/0/0
  !
 !
!
end

 XR2 

hostname XR2
interface Loopback0
 ipv4 address 2.2.2.2/32
!
interface GigabitEthernet0/0/0/0
 ipv4 address 192.168.12.2/24
!
interface GigabitEthernet0/0/0/1
 ipv4 address 192.168.23.2/24
!
router ospf 1
 router-id 2.2.2.2
 summary-prefix 172.16.0.0/22
 redistribute eigrp 1
 area 0
  interface GigabitEthernet0/0/0/1
  !
 !
!
router eigrp 1
 address-family ipv4
  router-id 2.2.2.2
  default-metric 1 1 1 1 1
  redistribute ospf 1
  interface GigabitEthernet0/0/0/0
  !
 !
!
end

 XR3 

hostname XR3
interface Loopback0
 ipv4 address 3.3.3.3/32
!
interface GigabitEthernet0/0/0/0
 ipv4 address 192.168.23.3/24
!
router ospf 1
 router-id 3.3.3.3
 area 0
  interface GigabitEthernet0/0/0/0
  !
 !
!
end

3.3. 解説

本タスクはASBRであるXR2でEIGRPの172.16.0.0/24、172.16.1.0/24、172.16.2.0/24、172.16.3.0/24を経路集約し、172.16.0.0/22としてOSPFに再配送することが要求されています。ASBRでの経路集約はsummary-prefixコマンドで設定できるため、XR2で次のコマンドが必要になります。

(config)# router ospf 1
(config-ospf)# summary-prefix 172.16.0.0/22

上記のsummary-prefixコマンドを投入する前のXR3のルーティングテーブルを確認してみましょう。

RP/0/0/CPU0:XR3#show route ospf
Tue Feb 11 01:40:30.821 UTC

O E2 172.16.0.0/24 [110/20] via 192.168.23.2, 00:13:25, GigabitEthernet0/0/0/0
O E2 172.16.1.0/24 [110/20] via 192.168.23.2, 00:13:25, GigabitEthernet0/0/0/0
O E2 172.16.2.0/24 [110/20] via 192.168.23.2, 00:13:25, GigabitEthernet0/0/0/0
O E2 172.16.3.0/24 [110/20] via 192.168.23.2, 00:13:25, GigabitEthernet0/0/0/0
O E2 192.168.12.0/24 [110/20] via 192.168.23.2, 00:13:25, GigabitEthernet0/0/0/0

XR1のLo10、Lo11、Lo12、Lo13のネットワークである172.16.0.0/24、172.16.1.0/24、172.16.2.0/24、172.16.3.0/24がLSAタイプ5(O E2)として学習されています。

続いて、summary-prefixコマンド投入後のXR3のルーティングテーブルを確認してみましょう。

RP/0/0/CPU0:XR3#show route ospf
Tue Feb 11 01:48:18.029 UTC

O E2 172.16.0.0/22 [110/20] via 192.168.23.2, 00:01:23, GigabitEthernet0/0/0/0
O E2 192.168.12.0/24 [110/20] via 192.168.23.2, 00:21:12, GigabitEthernet0/0/0/0

172.16.0.0/24、172.16.1.0/24、172.16.2.0/24、172.16.3.0/24のルートが削除され、代わりに集約された172.16.0.0/22のルートを学習していることが分かります。

3.4. 動作確認

3.4.1. show route ospf

show route ospfコマンドで以下を確認します。
・XR3で172.16.0.0/22をLSAタイプ5(O E2)として学習していること。

RP/0/0/CPU0:XR3#show route ospf
Tue Feb 11 02:02:25.021 UTC

O E2 172.16.0.0/22 [110/20] via 192.168.23.2, 00:15:30, GigabitEthernet0/0/0/0
O E2 192.168.12.0/24 [110/20] via 192.168.23.2, 00:35:19, GigabitEthernet0/0/0/0
3.4.2. ping

pingコマンドで以下を確認します。
・XR3からXR1のLo10、Lo11、Lo12、Lo13に到達性があること。

RP/0/0/CPU0:XR3#ping 172.16.0.1
Tue Feb 11 02:06:23.334 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/7/9 ms

RP/0/0/CPU0:XR3#ping 172.16.1.1
Tue Feb 11 02:06:27.434 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/5/9 ms

RP/0/0/CPU0:XR3#ping 172.16.2.1
Tue Feb 11 02:06:31.784 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/7/9 ms

RP/0/0/CPU0:XR3#ping 172.16.3.1
Tue Feb 11 02:06:35.404 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/5/9 ms