Mikan Network Lab.

ネットワーク技術やCisco製品に関して、勉強・検証した内容を発信しています。

Mikan Network Lab.

IOS-XR: Auto-RPの設定

Cisco IOS-XRにおけるAuto-RPの設定方法を記載します。

目次

1. 前提条件

本記事は以下に基づいて作成しています。
・Cisco VIRL 1.6.65
・Cisco IOS XR Software, Version 6.1.3

2. 要件

  • Senderから239.1.1.1宛にマルチキャストパケットを送信すると、Reciverから応答が得られるように設定する。
  • RPの選出はAuto-RPを使用し、XR2をRP CandidateおよびRP Mapping Agentに設定する。

構成図

3. 設定例

3.1. コンフィグ

要件を満たす設定例を以下に示します。

 XR1 

hostname XR1
interface Loopback0
 ipv4 address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/0/0/0
 ipv4 address 192.168.12.1 255.255.255.0
!
interface GigabitEthernet0/0/0/1
 ipv4 address 192.168.13.1 255.255.255.0
!
interface GigabitEthernet0/0/0/2
 ipv4 address 192.168.1.1 255.255.255.0
!
router ospf 1
 area 0
  interface Loopback0
  !
  interface GigabitEthernet0/0/0/0
  !
  interface GigabitEthernet0/0/0/1
  !
  interface GigabitEthernet0/0/0/2
  !
 !
!
multicast-routing
 address-family ipv4
  interface GigabitEthernet0/0/0/0
   enable
  !
  interface GigabitEthernet0/0/0/1
   enable
  !
  interface GigabitEthernet0/0/0/2
   enable
  !
 !
!
end

 XR2 

hostname XR2
interface Loopback0
 ipv4 address 2.2.2.2 255.255.255.255
!
interface GigabitEthernet0/0/0/0
 ipv4 address 192.168.12.2 255.255.255.0
!
interface GigabitEthernet0/0/0/1
 ipv4 address 192.168.23.2 255.255.255.0
!
router ospf 1
 area 0
  interface Loopback0
  !
  interface GigabitEthernet0/0/0/0
  !
  interface GigabitEthernet0/0/0/1
  !
 !
!
multicast-routing
 address-family ipv4
  interface Loopback0
   enable
  !
  interface GigabitEthernet0/0/0/0
   enable
  !
  interface GigabitEthernet0/0/0/1
   enable
  !
 !
!
router pim
 address-family ipv4
  auto-rp mapping-agent Loopback0 scope 255
  auto-rp candidate-rp Loopback0 scope 255
 !
!
end

 XR3 

hostname XR3
interface Loopback0
 ipv4 address 3.3.3.3 255.255.255.255
!
interface GigabitEthernet0/0/0/0
 ipv4 address 192.168.13.3 255.255.255.0
!
interface GigabitEthernet0/0/0/1
 ipv4 address 192.168.23.3 255.255.255.0
!
interface GigabitEthernet0/0/0/2
 ipv4 address 192.168.3.3 255.255.255.0
!
router ospf 1
 area 0
  interface Loopback0
  !
  interface GigabitEthernet0/0/0/0
  !
  interface GigabitEthernet0/0/0/1
  !
  interface GigabitEthernet0/0/0/2
  !
 !
!
multicast-routing
 address-family ipv4
  interface GigabitEthernet0/0/0/0
   enable
  !
  interface GigabitEthernet0/0/0/1
   enable
  !
  interface GigabitEthernet0/0/0/2
   enable
  !
 !
!
end

3.2. 解説

コンフィグの解説を以下に記載します。

 XR2 

router pim
 address-family ipv4
  auto-rp mapping-agent Loopback0 scope 255
  auto-rp candidate-rp Loopback0 scope 255

  • auto-rp mapping-agentコマンドでXR2をRP Mapping Agentに設定し、Loopback0をRP Mapping Agentのアドレスにしている。scopeキーワードでRP-DiscoveryメッセージのTTLを255に設定している。
  • auto-rp candidate-rpコマンドでXR2をRP Candidateに設定し、Loopback0をRP Candidateのアドレスにしている。scopeキーワードでRP-AnnounceメッセージのTTLを255に設定している。

4. 動作確認

4.1. show pim rp mapping

RP CandidateおよびRP Mapping Agentの選出状況を確認します。

RP/0/0/CPU0:XR1#show pim rp mapping
Tue Aug 25 02:04:51.653 UTC
PIM Group-to-RP Mappings
Group(s) 224.0.0.0/4
  RP 2.2.2.2 (?), v2
    Info source: 2.2.2.2 (?), elected via autorp
      Uptime: 00:07:00, expires: 00:02:05

  • Auto-RPにより、RPが2.2.2.2、Mapping Agentが2.2.2.2に選出されている。


RP/0/0/CPU0:XR2#show pim rp mapping
Tue Aug 25 02:04:56.213 UTC
PIM Group-to-RP Mappings
Group(s) 224.0.0.0/4
  RP 2.2.2.2 (?), v2
    Info source: 2.2.2.2 (?), elected via autorp
      Uptime: 00:07:04, expires: 00:02:01

  • Auto-RPにより、RPが2.2.2.2、Mapping Agentが2.2.2.2に選出されている。


RP/0/0/CPU0:XR3#show pim rp mapping
Tue Aug 25 02:05:01.812 UTC
PIM Group-to-RP Mappings
Group(s) 224.0.0.0/4
  RP 2.2.2.2 (?), v2
    Info source: 2.2.2.2 (?), elected via autorp
      Uptime: 00:06:04, expires: 00:02:55

  • Auto-RPにより、RPが2.2.2.2、Mapping Agentが2.2.2.2に選出されている。

4.2. show mrib route

マルチキャストルーティングテーブルのエントリからルートを確認します。

RP/0/0/CPU0:XR1#show mrib route 239.1.1.1
Tue Aug 25 02:06:39.725 UTC

IP Multicast Routing Information Base
Entry flags: L - Domain-Local Source, E - External Source to the Domain,
    C - Directly-Connected Check, S - Signal, IA - Inherit Accept,
    IF - Inherit From, D - Drop, ME - MDT Encap, EID - Encap ID,
    MD - MDT Decap, MT - MDT Threshold Crossed, MH - MDT interface handle
    CD - Conditional Decap, MPLS - MPLS Decap, EX - Extranet
    MoFE - MoFRR Enabled, MoFS - MoFRR State, MoFP - MoFRR Primary
    MoFB - MoFRR Backup, RPFID - RPF ID Set, X - VXLAN
Interface flags: F - Forward, A - Accept, IC - Internal Copy,
    NS - Negate Signal, DP - Don't Preserve, SP - Signal Present,
    II - Internal Interest, ID - Internal Disinterest, LI - Local Interest,
    LD - Local Disinterest, DI - Decapsulation Interface
    EI - Encapsulation Interface, MI - MDT Interface, LVIF - MPLS Encap,
    EX - Extranet, A2 - Secondary Accept, MT - MDT Threshold Crossed,
    MA - Data MDT Assigned, LMI - mLDP MDT Interface, TMI - P2MP-TE MDT Interface
    IRMI - IR MDT Interface

(192.168.1.10,239.1.1.1) RPF nbr: 192.168.1.10 Flags: RPF
  Up: 00:08:11
  Incoming Interface List
    GigabitEthernet0/0/0/2 Flags: A, Up: 00:08:11
  Outgoing Interface List
    GigabitEthernet0/0/0/1 Flags: F NS, Up: 00:06:17

  • 239.1.1.1宛のマルチキャストパケットをGi0/0/0/2で受信し、Gi0/0/0/1から送信している。


RP/0/0/CPU0:XR2#show mrib route 239.1.1.1
Tue Aug 25 02:06:54.524 UTC

IP Multicast Routing Information Base
Entry flags: L - Domain-Local Source, E - External Source to the Domain,
    C - Directly-Connected Check, S - Signal, IA - Inherit Accept,
    IF - Inherit From, D - Drop, ME - MDT Encap, EID - Encap ID,
    MD - MDT Decap, MT - MDT Threshold Crossed, MH - MDT interface handle
    CD - Conditional Decap, MPLS - MPLS Decap, EX - Extranet
    MoFE - MoFRR Enabled, MoFS - MoFRR State, MoFP - MoFRR Primary
    MoFB - MoFRR Backup, RPFID - RPF ID Set, X - VXLAN
Interface flags: F - Forward, A - Accept, IC - Internal Copy,
    NS - Negate Signal, DP - Don't Preserve, SP - Signal Present,
    II - Internal Interest, ID - Internal Disinterest, LI - Local Interest,
    LD - Local Disinterest, DI - Decapsulation Interface
    EI - Encapsulation Interface, MI - MDT Interface, LVIF - MPLS Encap,
    EX - Extranet, A2 - Secondary Accept, MT - MDT Threshold Crossed,
    MA - Data MDT Assigned, LMI - mLDP MDT Interface, TMI - P2MP-TE MDT Interface
    IRMI - IR MDT Interface

(*,239.1.1.1) RPF nbr: 2.2.2.2 Flags: C RPF
  Up: 00:07:56
  Incoming Interface List
    Decapstunnel0 Flags: A, Up: 00:07:56
  Outgoing Interface List
    GigabitEthernet0/0/0/1 Flags: F NS, Up: 00:07:56

(192.168.1.10,239.1.1.1) RPF nbr: 2.2.2.2 Flags: L RPF
  Up: 00:08:24
  Incoming Interface List
    Decapstunnel0 Flags: A, Up: 00:06:29

  • スイッチオーバー機能により最短経路で通信を行うため、RPを経由していない。


RP/0/0/CPU0:XR3#show mrib route 239.1.1.1
Tue Aug 25 02:07:00.764 UTC

IP Multicast Routing Information Base
Entry flags: L - Domain-Local Source, E - External Source to the Domain,
    C - Directly-Connected Check, S - Signal, IA - Inherit Accept,
    IF - Inherit From, D - Drop, ME - MDT Encap, EID - Encap ID,
    MD - MDT Decap, MT - MDT Threshold Crossed, MH - MDT interface handle
    CD - Conditional Decap, MPLS - MPLS Decap, EX - Extranet
    MoFE - MoFRR Enabled, MoFS - MoFRR State, MoFP - MoFRR Primary
    MoFB - MoFRR Backup, RPFID - RPF ID Set, X - VXLAN
Interface flags: F - Forward, A - Accept, IC - Internal Copy,
    NS - Negate Signal, DP - Don't Preserve, SP - Signal Present,
    II - Internal Interest, ID - Internal Disinterest, LI - Local Interest,
    LD - Local Disinterest, DI - Decapsulation Interface
    EI - Encapsulation Interface, MI - MDT Interface, LVIF - MPLS Encap,
    EX - Extranet, A2 - Secondary Accept, MT - MDT Threshold Crossed,
    MA - Data MDT Assigned, LMI - mLDP MDT Interface, TMI - P2MP-TE MDT Interface
    IRMI - IR MDT Interface

(*,239.1.1.1) RPF nbr: 192.168.23.2 Flags: C RPF
  Up: 00:08:50
  Incoming Interface List
    GigabitEthernet0/0/0/1 Flags: A NS, Up: 00:08:03
  Outgoing Interface List
    GigabitEthernet0/0/0/2 Flags: F NS LI, Up: 00:08:50

(192.168.1.10,239.1.1.1) RPF nbr: 192.168.13.1 Flags: RPF
  Up: 00:06:38
  Incoming Interface List
    GigabitEthernet0/0/0/0 Flags: A, Up: 00:06:38
  Outgoing Interface List
    GigabitEthernet0/0/0/2 Flags: F NS, Up: 00:06:38

  • 239.1.1.1宛のマルチキャストパケットをGi0/0/0/0で受信し、Gi0/0/0/2から送信している。

4.3. ping

Receiverから応答があることを確認します。

Sender#ping 239.1.1.1 repeat 5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 239.1.1.1, timeout is 2 seconds:

Reply to request 0 from 192.168.3.10, 11 ms
Reply to request 1 from 192.168.3.10, 5 ms
Reply to request 2 from 192.168.3.10, 5 ms
Reply to request 3 from 192.168.3.10, 4 ms
Reply to request 4 from 192.168.3.10, 6 ms

  • 192.168.3.10(Receiver)から応答が得られている。